Announcement

Collapse

Forum rules and expectations

Hello, and welcome to the forums at the Nautilus Drydocks, formerly Sub-driver.com!

We welcome anyone with a passion for submarines and a desire to learn and share knowledge about this fascinating hobby. Use of these forums indicates your intention to abide by our code of conduct:


1. No spam. All automated messages, advertisements, and links to competitor websites will be deleted immediately.

2. Please post in relevant sub-forums only. Messages posted in the wrong topic area will be removed and placed in the correct sub-forum by moderators.

3. Respect other users. No flaming or abusing fellow forum members. Users who continue to post inflammatory, abusive comments will be deleted from the forum after or without a warning.

4. No threats or harassment of other users will be tolerated. Any instance of threatening or harassing behavior is grounds for deletion from the forums.

5. No profanity or pornography is allowed. Posts containing adult material will be deleted.

6. No re-posting of copyrighted materials or other illegal content is allowed. Any posts containing illegal content or copyrighted materials will be deleted.
See more
See less

Ballast servo issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ballast servo issue

    Iím currently assembling a 2.5Ē Subdriver. Iím having trouble with the ballast servo. When hooked up to my receiver and turned on, it moves very little. I thought it was a bad servo, so I replaced it. I am having the same problem. However, if I push on the ballast linkage, it will work for a few moments, then not work. Iím using a Sub Tech receiver and a VEX radio. Iíve tried adjusting the trim, but no go.

    Any help would be greatly appreciated.

    Thx
    Farlan Clutters

  • #2
    Originally posted by secrtwpn View Post
    Iím currently assembling a 2.5Ē Subdriver. Iím having trouble with the ballast servo. When hooked up to my receiver and turned on, it moves very little. I thought it was a bad servo, so I replaced it. I am having the same problem. However, if I push on the ballast linkage, it will work for a few moments, then not work. Iím using a Sub Tech receiver and a VEX radio. Iíve tried adjusting the trim, but no go.

    Any help would be greatly appreciated.

    Thx
    Farlan Clutters
    sounds like the pushrod is hanging up -- either within the seal or something is blocking travel of the arm that engages the vent valve. If all else fails, send the unit to me for a fix.

    David
    "... well, that takes care of Jorgenson's theory!"

    Comment


    • #3
      The Subdriver is on its way to you...............................

      Comment


      • #4
        Originally posted by secrtwpn View Post
        The Subdriver is on its way to you...............................
        Very good. I'll jump on it the moment I get it.

        David
        "... well, that takes care of Jorgenson's theory!"

        Comment


        • #5
          Just checking to see if you received my Subdriver. The USPS tracking is not working!!!!!!

          Comment


          • #6
            Originally posted by secrtwpn View Post
            Just checking to see if you received my Subdriver. The USPS tracking is not working!!!!!!
            Nope. Not yet.

            David
            "... well, that takes care of Jorgenson's theory!"

            Comment


            • #7
              I shipped it Friday. It's still at the post office!!!!!! Grrrrrrr

              Comment


              • #8
                Well, the PO said it is not there..........It's probably enroute to somewhere......Let me know when/if you receive it..............

                Comment


                • #9
                  UPDATE!!!!! The USPS found my Subdriver and shipped it. It SHOULD be on your doorstep Wednesday afternoon.......... Also, I understand you helped design the Moebius Skipjack. I am impressed on how the parts seem to ďdrop intoĒ the hull with a minimum of modification. I heard Moebius lost their shirt on the kit. Too bad. It was a great idea! Good Work!

                  Comment


                  • #10
                    Originally posted by secrtwpn View Post
                    UPDATE!!!!! The USPS found my Subdriver and shipped it. It SHOULD be on your doorstep Wednesday afternoon.......... Also, I understand you helped design the Moebius Skipjack. I am impressed on how the parts seem to ďdrop intoĒ the hull with a minimum of modification. I heard Moebius lost their shirt on the kit. Too bad. It was a great idea! Good Work!
                    Nope. It was a bad idea well executed.

                    David
                    "... well, that takes care of Jorgenson's theory!"

                    Comment

                    Working...
                    X