Announcement

Collapse

Forum rules and expectations

Hello, and welcome to the forums at the Nautilus Drydocks, formerly Sub-driver.com!

We welcome anyone with a passion for submarines and a desire to learn and share knowledge about this fascinating hobby. Use of these forums indicates your intention to abide by our code of conduct:


1. No spam. All automated messages, advertisements, and links to competitor websites will be deleted immediately.

2. Please post in relevant sub-forums only. Messages posted in the wrong topic area will be removed and placed in the correct sub-forum by moderators.

3. Respect other users. No flaming or abusing fellow forum members. Users who continue to post inflammatory, abusive comments will be deleted from the forum after or without a warning.

4. No threats or harassment of other users will be tolerated. Any instance of threatening or harassing behavior is grounds for deletion from the forums.

5. No profanity or pornography is allowed. Posts containing adult material will be deleted.

6. No re-posting of copyrighted materials or other illegal content is allowed. Any posts containing illegal content or copyrighted materials will be deleted.
See more
See less

Es2 debugging

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Es2 debugging

    I am building a RECAB-R system for my 2nd HARPOON TYPE submarine. I was able to use this ES2 unit from the Sub Driver folks. It controls the pump and solenoid valve by the left JOYSTICK of the transmitter. to run pump, lever to the right. And to open the solenoid valve lever to the left. It did everything it is supposed to from the debugging until I disassembled my sub to clean up/tidy up the worksmanship. After that, I reassembled. the open solenoid valve command on the left joy stick of the transmitter, lever push to left does not open the solenoid valve. I checked if the valve is bad. Using power direct from another battery it opened. I checked the voltage when lever is pushed to open the valve. It reads 8+ volts. I went back to try to recalibrate using the protocol provided. It does not respond to changes or nothing happens. Failing at this, I bought a new ES2 unit from Caswell. it too will not open the solenoid valve. It does not react to the debugging protocall either since it was working for awhile before.
    Any one familiar with this unit?? I had many runs on this hardware. so it worked before.
    Appreciate any help here.

    creator of the Harpoon type stealth rc subs.

  • #2
    Right now your ES2 is plugged into port #4 of the receiver. Switch to another port of the receiver and see if you can get the solenoid to work off that.

    Another thing: is your transmitter capable of changing the 'servo' end-points. If so, check your limits on ch-4 -- maybe you fiddled with the transmitter and pushed the solenoid end of stick travel past the ES2 limits.

    M
    "... well, that takes care of Jorgenson's theory!"

    Comment


    • #3
      tried this. no changes. transmitter end points checked. not restricted. thanks. I reposted this problem with my wiring diagram and describing what I have tried so far.

      Comment

      Working...
      X